home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / app-crypt / chntpw-0.99.3.20040818 / chntpw-0.99.3.20040818.ebuild < prev    next >
Text File  |  2005-12-21  |  777b  |  33 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild,v 1.6 2005/04/09 22:17:33 vanquirius Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="Offline Windows NT Password & Registry Editor"
  8. HOMEPAGE="http://home.eunet.no/~pnordahl/ntpasswd/"
  9. MY_PV="${PV/*200/0}"
  10. LICENSE="chntpw"
  11. SLOT="0"
  12. KEYWORDS="~x86 ~ppc"
  13. DEPEND="dev-libs/openssl
  14.     app-arch/unzip"
  15. SRC_URI="http://home.eunet.no/~pnordahl/ntpasswd/chntpw-source-${MY_PV}.zip"
  16. IUSE=""
  17. S="${WORKDIR}"
  18.  
  19. src_unpack() {
  20.     unpack ${A}
  21.     epatch ${FILESDIR}/${P}-gcc4.diff
  22. }
  23.  
  24. src_compile() {
  25.     emake LIBS="-lcrypto" CFLAGS="${CFLAGS}" || die "emake failed"
  26. }
  27.  
  28. src_install() {
  29.     into /usr
  30.     dobin chntpw
  31.     dodoc *.txt
  32. }
  33.